Vagrant 1.8 Upgrade Issues

Vagrant 1.8 Upgrade Issues

Earlier this morning Mitchell Hashimoto released version 1.8 of Vagrant. I immediately upgraded and quickly hit a problem. After running vagrant up I got this error message:

Vagrant failed to initialize at a very early stage:

The plugins failed to load properly. The error message given is
shown below.

The RubyEncoder loader is not installed. Please visit the http://www.rubyencoder.com/loaders/ RubyEncoder site to download the required loader


Luckily Mitchell Hashimoto was able to fix the issue pretty quickly and re-released a new version of Vagrant 1.8 release which fixed this issue. But after running vagrant up again another error hit me hard:

An unexpected error occurred while loading the Vagrant VMware
provider. Please contact support with the following
error code: '7'.
Vagrant failed to initialize at a very early stage:

The plugins failed to load properly. The error message given is
shown below.

exit


As it turns out I had a pretty old version of the vagrant-vmware-workstation plugin installed which no longer seems to be compatible with the latest version of Vagrant. First I tried to run the vagrant plugin update command which told me that there were no updates for the vagrant-vmware-workstation plugin available. Then I tried to uninstall and re-install the plugin which in the end worked fine.



Tags: ,

Eintrag von Stephan Hochdörfer am 22.12.2015

comments powered by Disqus